Table of Contents

This article was tested only on Turris 1.x.
But it should work also on Turris Omnia.

How to configure and setup Vodafone K5150

What do you need to have?

In this article I will show you how to configure LTE USB modem Vodafone K5150.
Also I will also show you how to have mobile broandband as backup connection (failover).

Information about used LTE USB modem (which you can find by using SSH):

root@turris:~# lsusb
Bus 001 Device 013: ID 12d1:1f16 Huawei Technologies Co., Ltd.

now you will need to check if usbmode -l sees the modem

root@turris:~# usbmode -l
Found device: 12d1:1f16 (Manufacturer: "Vodafone (Huawei)", Product: "K5150", Serial: "FFFFFFFFFFFFFFFF")

Required packages

In PuTTY or Terminal log into your router and install these packages:

opkg install kmod-usb-net-cdc-ether kmod-usb-net-cdc-mbim kmod-usb-net-cdc-ncm kmod-usb-net-huawei-cdc-ncm umbim

Adding interface w/o using LuCI

Because protocol wwan isn't supported in the advanced configuration interface called LuCI.
So I will show you 3 options.

1. In Windows you can use program WinSCP.
2. You can use vim
3. UCI.

Before you will continue you would need to know APN. Your's mobile operator should tell you, what needs to be there. Usually it is something like internet.

Opening and editing files

You will need to open file /etc/config/network and to the end you will add this:

config interface 'lte'
	option proto 'wwan'
	option ifname 'wwan0'
	option apn 'internet'

Save it. Now you must assign LTE interface to the firewall.

UCI

Just copy&paste these rows to your's shell.

uci set network.lte=interface
uci set network.lte.ifname='wwan0'
uci set network.lte.proto='wwan'
uci set network.lte.apn='internet'
uci commit

Now you must assign LTE interface to the firewall.

Assign LTE interface to the firewall

LuCI

Go to LuCI interface (by default should be located on http://192.168.1.1/cgi-bin/luci ) → NetworkFirewal

Edit 2nd zone (should be wan) and check there lte interface.

Click Save & Apply

Now you should see how KB moves in RX and TX. You can also check it by disconnecting WAN cable.

Opening and editing files

Open file /etc/config/firewall and locate config zone, where under it should be: option name 'wan'

If there isn't option network then copy&paste like it is below. If there is option network then you would need to add there interface lte as it is below.

config zone should be same like this one

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'lte wan wan6'

When connection doesn't work you need to restart router.

On LTE modem we can see LED.
Green light means 3G connection. Purple means 4G connection.

Now if everything went well all your traffic between the router and the Internet should go through the LTE interface. That means that the connection through the WAN interface will not work. In the next step I will show you how to configure LTE as a backup connection.

LTE as backup connection

Please go here, where it is explained: https://www.turris.cz/doc/en/howto/multiwan

microSD card

Tested only on Turris 1.x. Should be similar to Turris Omnia.

When you have inserted microSD card to LTE modem, which is connected to the Turris router, you will need to check if router sees microSD card in LTE modem.

I will use SSH:

blkid

You should see similar output as I do.

root@turris:~# blkid
/dev/mtdblock3: TYPE="squashfs"
/dev/mmcblk0: PTUUID="3fee9afa" PTTYPE="dos"
/dev/mmcblk0p1: SEC_TYPE="msdos" UUID="3462-1AE5" TYPE="vfat" PARTUUID="3fee9afa-01"
/dev/mmcblk0p2: UUID="1acf499c-1067-4fe1-b1b7-af7dc884f7ae" UUID_SUB="fd211a80-da78-49fc-a7c2-f2ed2b840301" TYPE="btrfs" PARTUUID="3fee9afa-02"
/dev/sda1: UUID="ED37-A894" TYPE="exfat"

Now we can see that microSD mounted is detected as dev/sda and their type is: exfat

By this command you can format it to ext4 file system

mkfs.ext4 /dev/sda1

You can also use LuCI to add new mount point in System tab.

(Turris 1.x owners can't add it through LuCI and will need to mount it manually)

or you can mount it manually

If you would like to have microSD card in folder sd, which will be located in /mnt First you will need to create folder sd in /mnt

mkdir /mnt/sd
mount /dev/sda1 /mnt/sd

Now I will show you how to verify, if sd card is mounted how we wanted.

root@turris:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p2          119.1G    136.5M    118.0G   0% /
tmpfs                  1011.5M      1.7M   1009.8M   0% /tmp
tmpfs                   512.0K      4.0K    508.0K   1% /dev
/dev/sda1               116.8G     60.0M    110.8G   0% /mnt/sd

Source: Thanks to Nora Kořánová, because she wrote article for Quectel EC20